Builder Platform Service Disruption

Incident Report for Builder.io

Resolved

The issue impacting the Builder platform has been fully resolved. All services are now operating normally.
Posted Aug 28, 2025 - 16:41 PDT

Update

We are continuing to monitor for any further issues.
Posted Aug 28, 2025 - 15:15 PDT

Monitoring

The Google Cloud Firestore team has addressed the underlying issue which caused the performance degradation. Traffic is now healthy across the site and APIs.
Posted Aug 28, 2025 - 15:14 PDT

Update

We have identified the issue affecting the Builder platform as stemming from problems with an upstream provider. Our team is working with the provider to mitigate the impact. We will continue to share updates as more information becomes available.
Posted Aug 28, 2025 - 14:41 PDT

Identified

We have identified the issue impacting the Builder platform, including the Content API and related services, and have taken steps toward recovery. Most services are now operational, though some customers may still experience intermittent issues. We will continue monitoring closely until full recovery is confirmed.
Posted Aug 28, 2025 - 14:12 PDT

Update

We are still actively investigating an incident that is impacting the Builder platform as a whole, including the Content API and related services. Our engineering team is actively working to identify the root cause and will provide updates as more information becomes available.
Posted Aug 28, 2025 - 13:39 PDT

Investigating

We are currently investigating a service disruption impacting the Content API service. Users may experience elevated error rates at this time. Our engineering team is actively working to identify the root cause. We will provide an update as soon as more information is available.
Posted Aug 28, 2025 - 13:24 PDT
This incident affected: Publish (Content Delivery APIs) and Cloud Providers (Google Cloud Platform Cloud Filestore).