We are still working with our upstream database provider to resolve the elevated p99 latency on the Content API. We will share another update as soon as information is available.
Posted Mar 20, 2026 - 13:49 PDT
Identified
We have determined that the elevated p99 latency on the Content API is caused by an issue with our upstream database provider. We are actively working with them to resolve the issue and will provide another update as soon as we have more information.
Posted Mar 20, 2026 - 11:49 PDT
Monitoring
We have identified that the elevated p99 latency on the Content API was caused by latency introduced by our upstream database provider. We are actively monitoring performance and will provide another update as soon as we have more information.
Posted Mar 20, 2026 - 09:53 PDT
Identified
We have identified a likely cause of the elevated p99 latency affecting the Content API. Customers may be experiencing slow API responses and timeouts/errors. Our team is actively investigating and working on a fix. We will provide another update as soon as we have more information.
Posted Mar 20, 2026 - 08:14 PDT
Investigating
p99 latency is elevated across the Content API
Posted Mar 20, 2026 - 06:42 PDT
This incident affected: Publish (Content Delivery APIs).